ctrl+shift+p filters: :st2 :st3 :win :osx :linux
Browse

Merlin

by cynddl ST2/ST3

Merlin package for Sublime Text 3

Details

Installs

  • Total 3K
  • Win 405
  • OS X 1K
  • Linux 833
Nov 15 Nov 14 Nov 13 Nov 12 Nov 11 Nov 10 Nov 9 Nov 8 Nov 7 Nov 6 Nov 5 Nov 4 Nov 3 Nov 2 Nov 1 Oct 31 Oct 30 Oct 29 Oct 28 Oct 27 Oct 26 Oct 25 Oct 24 Oct 23 Oct 22 Oct 21 Oct 20 Oct 19 Oct 18 Oct 17 Oct 16 Oct 15 Oct 14 Oct 13 Oct 12 Oct 11 Oct 10 Oct 9 Oct 8 Oct 7 Oct 6 Oct 5 Oct 4 Oct 3 Oct 2 Oct 1
Windows 0 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 1 1 2 0 1 0 1 1 1 0 0 0 0 0 0
OS X 0 0 1 1 0 0 0 0 1 0 0 0 0 0 0 0 0 0 1 0 0 0 0 0 1 0 0 0 1 1 2 2 2 1 3 3 1 0 1 2 0 2 0 1 2 1
Linux 0 0 0 0 2 0 1 0 1 0 0 0 0 1 0 0 0 0 0 0 1 0 0 0 0 0 2 0 0 0 0 0 2 0 0 0 1 0 0 0 0 0 0 2 3 0

Readme

Source
raw.​githubusercontent.​com

Merlin for Sublime Text 3

About

This plugin for Sublime Text 3 allows you to analyse OCaml source code, autocomplete and infer types while writing. It checks automatically for syntax or type errors.

Installation

First of all, be sure to have merlin installed. The current supported version of merlin is 2.x. The shorter way of doing this is with opam, an OCaml package manager:

opam install merlin

Next, install the ‘Merlin’ package using Package Control or clone this repository in your Packages folder:

git clone https://github.com/cynddl/sublime-text-merlin.git Merlin

License

Sublime-Text-Merlin is licensed under the MIT License. See the file LICENSE.md for more details.