ctrl+shift+p filters: :st2 :st3 :win :osx :linux
Browse

Sublime​Linter-contrib-cloudformation

by fatbasstard ST3

SublimeLinter plugin for Cloudformation files

Details

  • 1.1.0
  • github.​com
  • github.​com
  • 10 months ago
  • 24 minutes ago
  • 2 years ago

Installs

  • Total 2K
  • Win 662
  • Mac 935
  • Linux 324
Sep 29 Sep 28 Sep 27 Sep 26 Sep 25 Sep 24 Sep 23 Sep 22 Sep 21 Sep 20 Sep 19 Sep 18 Sep 17 Sep 16 Sep 15 Sep 14 Sep 13 Sep 12 Sep 11 Sep 10 Sep 9 Sep 8 Sep 7 Sep 6 Sep 5 Sep 4 Sep 3 Sep 2 Sep 1 Aug 31 Aug 30 Aug 29 Aug 28 Aug 27 Aug 26 Aug 25 Aug 24 Aug 23 Aug 22 Aug 21 Aug 20 Aug 19 Aug 18 Aug 17 Aug 16
Windows 0 0 0 0 0 0 1 1 0 2 0 0 4 1 1 2 2 1 1 3 1 3 0 2 0 0 1 0 0 2 0 0 1 0 0 0 2 2 0 1 2 0 1 1 0
Mac 1 0 0 0 2 1 2 2 1 0 0 1 2 0 0 0 0 0 1 2 1 1 0 0 0 1 0 3 1 0 0 0 1 1 1 0 2 3 0 2 2 1 1 0 0
Linux 1 0 0 0 0 0 0 1 0 0 0 1 0 1 0 0 1 0 2 1 0 0 0 0 0 1 0 0 0 0 0 0 1 0 0 1 0 0 0 0 0 1 0 0 0

Readme

Source
raw.​githubusercontent.​com

SublimeLinter-contrib-cloudformation

Build Status

This linter plugin for SublimeLinter provides an interface to cfn-lint. This plugin lints yaml and json CloudFormation templates.

Installation

SublimeLinter must be installed in order to use this plugin.

Please use Package Control to install the linter plugin.

Before installing this plugin, you must ensure that cfn-lint is installed on your system.

pip install cfn-lint

Note: This plugin requires cfn-lint 0.2.2 or later.

Settings

For general information on how SublimeLinter works with settings, please see [Settings]. For information on generic linter settings, please see [Linter Settings][linter-settings].

You can configure cfn-lint by adding the following options to the Sublime Linter User Settings:

  • ignore_rules: Array of rules that should be ignored when testing the file
  • append_rules: Array of paths containing additional rules to be applied
  • override_spec: Path the a Specification Override file
  • include_checks: Array of rules that should be included when testing the file
    • This setting requires v0.8.0 or later.

Example:

{
  "linters": {
    "cfnlint": {
      "ignore_rules": ["W2507", "W2508"],
      "append_rules": ["/path/to/custom/rules"],
      "override_spec": "/path/to/override.json",
      "include_checks": ["I"]
    }
  }
}

For details about these settings, check the cfn-lint documentation