ctrl+shift+p filters: :st2 :st3 :win :osx :linux
Browse

LSP-elm

by sublimelsp ST3

Elm support for Sublime's LSP plugin

Details

  • 2.0.4
    2.0.3
  • github.​com
  • github.​com
  • 2 months ago
  • 36 minutes ago
  • 4 years ago

Installs

  • Total 731
  • Win 160
  • Mac 347
  • Linux 224
Apr 19 Apr 18 Apr 17 Apr 16 Apr 15 Apr 14 Apr 13 Apr 12 Apr 11 Apr 10 Apr 9 Apr 8 Apr 7 Apr 6 Apr 5 Apr 4 Apr 3 Apr 2 Apr 1 Mar 31 Mar 30 Mar 29 Mar 28 Mar 27 Mar 26 Mar 25 Mar 24 Mar 23 Mar 22 Mar 21 Mar 20 Mar 19 Mar 18 Mar 17 Mar 16 Mar 15 Mar 14 Mar 13 Mar 12 Mar 11 Mar 10 Mar 9 Mar 8 Mar 7 Mar 6
Windows 0 1 0 0 0 0 0 1 0 0 1 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
Mac 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 1 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 1 0 0 0 0 0 0 1 1
Linux 0 1 0 1 1 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

Readme

Source
raw.​githubusercontent.​com

LSP-elm

Elm support for Sublime's LSP plugin.

Requirements

Make sure you have NodeJS and NPM installed.

Installation

You will need to install elm and elm-test to get all diagnostics and elm-format for formatting.

npm install -g elm elm-test elm-format

If you want to use elm-review:

npm install -g elm-review

Configuration

Open configuration file using command palette with Preferences: LSP-elm Settings command or by accessing Preferences > Package Settings > LSP > Servers > LSP-elm from the sublime menu.

Visit elm-language-server for additional server configuration.